EKM App Maintenance
Incident Report for EKM
Resolved
This incident has been resolved.
Posted Jul 05, 2022 - 07:59 BST
Investigating
We are currently working on an issue with the EKM Mobile App which is preventing users from logging in. This is only impacting the EKM mobile App and customers are still able to log in to their EKM account via ekm.com. No other services are impacted.
Posted Jun 24, 2022 - 16:39 BST
This incident affected: General Services (EKM App).