Issues with EKM Mail
Incident Report for EKM
Resolved
This incident has now been resolved and we sincerely apologise for the inconvenience caused.
Posted May 03, 2023 - 06:52 BST
Update
Our email provider has advised that, as of around 12:30am, normal service operations were restored, all users are now able to log in without issue, and all new send requests are being processed as expected. The remaining backlog of inbound email requests may take up to 12 hours to clear.

This incident will now be marked as closed. We sincerely apologise for the impact this service interruption has had.
Posted May 03, 2023 - 06:50 BST
Update
Our email provider is now actively processing backlogged email requests. Users may continue to experience intermittent login issues and delays in sending and receiving email over the next few hours. By 12am, we expect the majority of the backlog to be cleared and for our email service to be functioning normally. We apologise for any inconvenience in the meantime.
Posted May 02, 2023 - 20:11 BST
Update
Users are still experiencing login issues as well as delays and failures to send and receive email. Our email provider is continuing the recovery process to restore service.
Posted May 02, 2023 - 17:02 BST
Identified
Restoration efforts are underway from our email provider. There will be no data or email loss. Both inbound and outbound emails will be delivered gradually upon full restoration of the service.
Posted May 02, 2023 - 14:16 BST
Investigating
We are aware of an issue that is preventing users from using the email services either through a mail client or webmail. Our third party provider are investigating and hoping to restore normal service promptly.
Posted May 02, 2023 - 07:54 BST
This incident affected: General Services (EKM Mail).