Issues accessing accounts at ekm.com
Incident Report for EKM
Resolved
This incident has now been resolved. Many thanks for your patience and sorry for any inconvenience caused.
Posted Jul 13, 2023 - 09:06 BST
Investigating
We are currently investigating an issue preventing access to ekm.com, as a matter of urgency. We apologise for any inconvenience and will update as a priority.
Posted Jul 13, 2023 - 08:55 BST
This incident affected: General Services (EKM.com).