Issues with EKM Mail
Incident Report for EKM
Resolved
Thank you for your patience. Outbound email delays have now been resolved.
Posted Feb 16, 2024 - 13:12 GMT
Investigating
We are currently seeing outbound email delays when sending from EKM Mail. We are investigating this with our email provider
Posted Feb 16, 2024 - 08:31 GMT
This incident affected: General Services (EKM Mail).