Issues with automated Shop Emails
Incident Report for EKM
Resolved
The incident has now been resolved. Apologies for any inconvenience caused
Posted Dec 22, 2023 - 13:39 GMT
Investigating
We are investigating an issue impacting the automated emails being sent from the shop, including emails such as the order notifications. We are working on this and hoping to restore normal service promptly. Apologies for any inconvenience
Posted Dec 22, 2023 - 09:25 GMT
This incident affected: Shop Services (Your Account).