Our team has implemented a fix for the SMTP error. However, we’re currently unable to identify which accounts were affected. If you are still experiencing SMTP errors when sending emails via Webmail, please reach out to our support team as soon as possible so we can resolve this for you. We appreciate your patience and understanding.
Posted Jul 14, 2025 - 13:30 BST
Update
Whilst we continue to investigate the underlying cause of the issue, we do need affected accounts to log the problem with our support team if they haven't already.
This will ensure that, once a solution is found, we can apply the fix to your account promptly.
Posted Jul 14, 2025 - 10:55 BST
Investigating
We are currently investigating an issue that is preventing emails from being sent, which is resulting in an SMTP error. Please note that this does not affect all accounts.
Posted Jul 14, 2025 - 10:14 BST
This incident affected: General Services (EKM Mail).