Issue logging in to the EKM Email Marketing feature.

Incident Report for EKM

Resolved

A fix has been applied and is being monitored - users can now log in as normal. Apologies for any inconvenience caused
Posted May 16, 2025 - 16:29 BST

Investigating

We are currently investigating an issue logging in to the EKM Email Marketing feature.
Posted May 16, 2025 - 14:21 BST
This incident affected: General Services (EKM Email Marketing).