Issues logging in
Incident Report for EKM
Resolved
This incident has been resolved.
Posted Jun 08, 2023 - 13:30 BST
Investigating
We are currently investigating an issue impacting the accounts being inaccessible and some issues logging in. We are working to restore normal service as quickly as possible and apologise for any inconvenience caused.
Posted Jun 08, 2023 - 12:46 BST
This incident affected: Shop Services (Login, Your Account).