The checkout issue has now been resolved, and payments can now be taken successfully. Further information will be provided to all affected EKM Shop Owners regarding any end customers who placed or attempted to place an order while the issue was being resolved. We appreciate your patience and sincerely apologise for the inconvenience this has caused.
Posted Jul 31, 2025 - 18:22 BST
Update
The Engineering Team are still working on this fix as a matter of urgency. We appreciate your patience and apologise for the inconvenience caused.
Posted Jul 31, 2025 - 16:38 BST
Update
While the checkout issue is being fixed, Shop Owners may temporarily experience slower back-end load times, and some features may not load at all. This is expected as part of the fix process, and we appreciate your continued patience.
Posted Jul 31, 2025 - 13:45 BST
Identified
We have identified a issue affecting some EKM Shops, that is preventing end customers from completing the checkout process. This is being investigated as a matter of urgency and a further update will be provided as soon as possible. We apologise for the inconvenience caused.