Email Login Issue
Incident Report for EKM
Resolved
This issue has now been resolved. Many thanks for your patience.
Posted Jul 20, 2023 - 09:43 BST
Investigating
Our email provider has made us aware that a small amount of users may have issues logging in to their email account. This is currently being investigated and we will provide another update ASAP. We apologise for any inconvenience caused.
Posted Jul 20, 2023 - 09:27 BST
This incident affected: General Services (EKM Mail).