Inbound Calls Unavailable

Incident Report for EKM

Resolved

This incident has been resolved.
Posted Aug 21, 2026 - 09:37 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2026 - 09:27 BST

Investigating

We’re currently experiencing an issue with our telephony provider that is preventing us from receiving calls.

Our team is working with the provider to resolve the issue as quickly as possible. We’ll provide another update once we have more information.

In the meantime, support is still available

Our live chat and ticketing system remain fully operational, so you can still contact our support team:

Email: support@ekm.com
Live chat - This is accessible via the backend of your EKM shop
Posted Aug 21, 2026 - 09:10 BST
This incident affected: Support (Email Support, Live Chat Support, Phone Support, Ticket Support).