Mail Issues For Some Users
Incident Report for EKM
Resolved
This issue has now been resolved. We apologise for any inconvenience caused.
Posted May 11, 2023 - 07:25 BST
Investigating
Our mail provider is investigating an issue that is affecting some users logging in, sending and receiving mail. We apologise for any inconvenience caused and will further update as soon as we have more information.
Posted May 11, 2023 - 06:40 BST
This incident affected: General Services (EKM Mail).