Webmail Login Issue
Incident Report for EKM
Resolved
This issue has now been resolved. We apologise for any inconvenience and thank you for your patience.
Posted Dec 11, 2023 - 14:48 GMT
Investigating
Our mail provider is investigating an issue preventing a small number of users from logging into Webmail. We apologise for any inconvenience caused and will provide an update once we have additional information.
Posted Dec 11, 2023 - 12:40 GMT
This incident affected: General Services (EKM Mail).