EKM Mail - Inbound Email Delays
Incident Report for EKM
Resolved
The backlog has now been fully cleared and incident resolved. We apologise for any inconvenience and thankyou for your patience.
Posted Aug 01, 2023 - 19:31 BST
Monitoring
The error causing delays has been found. At this time the issue has been resolved and we are waiting for the queue backlog to clear. Another update will be posted in due course. Sorry for the inconvenience and thankyou for your patience.
Posted Aug 01, 2023 - 18:25 BST
Investigating
We are currently experiencing inbound mail delays on EKM Mail. Our engineering team and email provider are investigating the issue.

We will provide an update once we have additional information.
Posted Aug 01, 2023 - 16:43 BST
This incident affected: General Services (EKM Mail).