Webmail login issues for some users
Incident Report for EKM
Resolved
This incident has now been resolved
Posted Feb 22, 2024 - 17:18 GMT
Investigating
Our mail provider is investigating an issue preventing some users from logging into Webmail. We apologise for any inconvenience and will provide an update once we have additional information.
Posted Feb 22, 2024 - 15:52 GMT
This incident affected: General Services (EKM Mail).