EKM Mail delays
Incident Report for EKM
Resolved
This incident has now been resolved. We appreciate your patience and apologise for any inconvenience caused.
Posted Feb 20, 2024 - 17:29 GMT
Investigating
We are currently experiencing inbound mail delays, slowness, and IMAP failures in Webmail. Our mail provider is investigating the issue as a priority. We apologise for any inconvenience caused and will provide an update once we have additional information.
Posted Feb 20, 2024 - 16:36 GMT
This incident affected: General Services (EKM Mail).