Orders Section loading issue on EKM online shops

Incident Report for EKM

Resolved

Update: This issue has now been resolved.
Posted Jul 13, 2026 - 17:31 BST

Update

Update: This issue has now been resolved.
Posted Jul 13, 2026 - 17:31 BST

Investigating

Our Engineering Team are aware and currently investigating this issue. Further updates will provided shortly.
Posted Jul 13, 2026 - 17:25 BST
This incident affected: General Services (EKM.com).