Problems with Payments on EKMPay
Incident Report for EKM
Resolved
This incident has now been resolved
Posted Jul 31, 2023 - 11:55 BST
Investigating
We are aware of an issue that is affecting payments using EKMPay which may see an increase in payments being declined. This is due to an issue with the 3DSecure checks being completed.

We apologise for any problems that this may be causing and want to assure you that the team are actively investigating this and will implement a resolution as quickly as possible to minimise any impact to your business.

You can also see updates to this on https://www.clearaccept.com/statusupdates
Posted Jul 31, 2023 - 10:19 BST
This incident affected: Shop Services (Payment Gateways).