Email Marketing - Delays in sending
Incident Report for EKM
Resolved
This incident has now been resolved. Apologies for any inconvenience that this may have caused.
Posted Aug 16, 2023 - 08:13 BST
Update
We are continuing to investigate the issues with the email marketing feature and the delays in sending campaigns at this time
Posted Aug 14, 2023 - 13:00 BST
Investigating
We are currently investigating an issue which is causing a delay in sending of campaigns using the EKM Email Marketing feature.
Posted Aug 11, 2023 - 16:53 BST
This incident affected: General Services (EKM Email Marketing).