Global Issue with Mastercard payments
Incident Report for EKM
Resolved
This issue has now been resolved.
Posted Jun 12, 2023 - 18:54 BST
Investigating
We're currently aware of issues globally with Mastercard payments due to a card network issue. We believe this outage is outside of EKM's infrastructure. We’re monitoring for updates and will post further information here as we receive it.
Posted Jun 12, 2023 - 16:52 BST
This incident affected: Shop Services (Payment Gateways).