Issue with EKM Support Live Chat
Incident Report for EKM
Resolved
This incident has now been resolved
Posted Nov 03, 2023 - 14:32 GMT
Investigating
We are currently investigating an issue affecting EKM Support Live Chat. We would recommend that you email any queries to support@ekm.com and we will get back to you or call 0333 004 0333 to speak to a member of the team.
Posted Nov 03, 2023 - 09:29 GMT
This incident affected: Support (Live Chat Support).