Issues with PayPal Checkout
Incident Report for EKM
Resolved
This incident has now been resolved
Posted Jul 06, 2023 - 09:00 BST
Investigating
We are currently aware that PayPal are experiencing a system issue which is affecting their Online checkout. PayPal users may be experiencing a blank page with a spinner when trying to pay by credit card preventing them from completing the payment.

You can find more about this here - https://www.paypal-status.com/incident/production
Initial Notification: Impact to PayPal Online Checkout (PP-LIVE-66022)
Posted Jul 05, 2023 - 12:26 BST
This incident affected: Shop Services (Payment Gateways).