Webmail - Email Sending Issue

Incident Report for EKM

Resolved

The email sending issue has now been resolved. We appreciate your patience and apologise for any inconvenience caused.
Posted May 12, 2026 - 17:41 BST

Investigating

Our mail provider is currently investigating an issue where some users are experiencing difficulties when trying to send mail.

We are sorry for any inconvenience caused and will provide an update once we have additional information.
Posted May 12, 2026 - 17:38 BST
This incident affected: General Services (EKM Mail).