Internal System Error

Incident Report for EKM

Resolved

This issue has now been resolved. We appreciate your patience and apologise for any inconvenience caused.
Posted Jun 12, 2025 - 16:39 BST

Investigating

We are currently investigating an issue impacting a small number of customers who are unable to view their live sites due to an internal system error. Our Engineering Team are working on this as a matter of urgency. We apologise for any inconvenience this may cause.
Posted Jun 12, 2025 - 16:20 BST
This incident affected: Shop Services (Shop Front, Your Account).