EKM.com is down
Incident Report for EKM
Resolved
This incident has been resolved.
Posted Jun 04, 2023 - 08:29 BST
Monitoring
Access to EKM.com has been restored and we are closely monitoring the situation to ensure it remains available.
Posted Jun 04, 2023 - 08:12 BST
Investigating
We are currently investigating an issue with EKM.com preventing customers from logging in to their accounts. Actual front end websites are working fine. We apologise for any inconvenience caused and are working to restore normal service as quickly as possible.
Posted Jun 04, 2023 - 08:02 BST
This incident affected: General Services (EKM.com).